Forums

Controls, failed to create a type
Last Post 09 Jun 2016 06:58 PM by Bart. 2 Replies.
Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
BartUser is Offline
New Member
New Member
Posts:2


--
05 Jun 2016 10:21 AM
    Hi everyone,

    I've been experimenting and building with Empty Keys. I am pursuing game making as a hobby project.

    I got a lot of the EK features to work so far.
    What doesn't work for me is when I try to make a user-control for the actual in-game screen. What happens is that the EK UI generator (apparantly) gets confused about the namespace, can't find and create the control... Even though Visual Studio can find the code if you peek at it in the XAM, for example.

    To me this means that the namespace appears to be correct, but that the UI Generator throws an error about it. Perhaps it only supports controls in a different assembly, as in the example project. But I couldn't get that work either.

    -----------
    #error: ''Failed to create a 'Type' from the text 'general:ChatWindow'.
    ----------


    Can you tell me what I am doing wrong?
    Or what I need to change to get it to work?

    This is a link to the project,

    https://www.dropbox.com/s/2qkfd4h7xu5f5ek/AetasParadigm.rar?dl=0


    Sincerest regards,

    Me.
    Filip DušekUser is Offline
    Advanced Member
    Advanced Member
    Posts:669


    --
    05 Jun 2016 11:39 AM
    Use assembly in namespace declaration. You should separate your code from views (XAML files) too. Look at the examples on GitHub (CustomWindow class).
    BartUser is Offline
    New Member
    New Member
    Posts:2


    --
    09 Jun 2016 06:58 PM
    Thanks for your reply Filip. I will try that approach.
    You are not authorized to post a reply.