Forums

CocosSharp 1.6.0.2 problem
Last Post 07 Oct 2015 01:33 PM by Filip Dušek. 10 Replies.
Printer Friendly
  •  
  •  
  •  
  •  
  •  
Sort:
PrevPrev NextNext
You are not authorized to post a reply.
Author Messages
Johannes SjøkvistUser is Offline
New Member
New Member
Posts:47


--
01 Oct 2015 09:01 AM
    When using 1.6.0.2 version of CocosSharp, there is a problem that makes CocosSharp sprites not being rendered. I can only see emptykeys UI.
    Version 1.6.0.1 of CocosSharp works.

    The UI is rendered just fine, but if I add sprites to the CCLayer, they are not showing like before...

    Here is the changes they made in the latest verison:
    https://github.com/mono/CocosSharp/issues/316

    Do you need to build against that version maybe?

    And about the other AOT bug: The latest Alpha of Xamarin.iOS has the fix included!
    So I can now build to real iOS device finally!
    Filip DušekUser is Offline
    Advanced Member
    Advanced Member
    Posts:695


    --
    01 Oct 2015 09:15 AM
    I didn't do any test with 1.6.X.X yet, so It might be just simple recompile issue. Next version is planned on 12th October, but could be postponed (depends on release of new MonoGame). Can you use 1.6.0.1 or is 1.6.0.2 really needed for something?

    Great news about iOS!
    Johannes SjøkvistUser is Offline
    New Member
    New Member
    Posts:47


    --
    01 Oct 2015 09:38 AM
    1.6.0.1 can be used for now. 1.6.0.2 is just for performance... So I can wait for the next version.
    Filip DušekUser is Offline
    Advanced Member
    Advanced Member
    Posts:695


    --
    06 Oct 2015 09:39 AM
    I'm testing 1.6.0.2 and I don't see any unusual behavior. I got 2 layers, bottom CCLayerColor with just Red background and CCLayer on top with UI. What's your scenario? Do you have sprites in UI Layer or it has it's own?
    Johannes SjøkvistUser is Offline
    New Member
    New Member
    Posts:47


    --
    06 Oct 2015 11:57 AM
    I have sprites in UI Layer that should be placed on top of emptykeys. In 1.6.0.2 they are invisible, but touchable... If I downgrade to 1.6.0.1, that scenario works.
    Johannes SjøkvistUser is Offline
    New Member
    New Member
    Posts:47


    --
    06 Oct 2015 12:22 PM
    How do I get resubscribed to emails here?
    I clicked by mistake on unsubscribe link in one of the emails, and have not got any updates since. So I need to manually check here.
    Clicking subscribe again here, does not work...
    Filip DušekUser is Offline
    Advanced Member
    Advanced Member
    Posts:695


    --
    06 Oct 2015 09:00 PM
    I put you back on mailing list, should work again if you subscribed to this thread.
    Johannes SjøkvistUser is Offline
    New Member
    New Member
    Posts:47


    --
    07 Oct 2015 09:10 AM
    Thank you!
    I got notified by mail, so it works!
    Filip DušekUser is Offline
    Advanced Member
    Advanced Member
    Posts:695


    --
    07 Oct 2015 11:15 AM
    Can you please try this in your code (root is UIRoot) ? Let me know if that helps.

    
            private void RenderUI()
            {
                var state = Window.Application.GraphicsDevice.RasterizerState;
                root.Draw(elapsedGameTime);
                Window.Application.GraphicsDevice.RasterizerState = state;
            }
    
    
    Johannes SjøkvistUser is Offline
    New Member
    New Member
    Posts:47


    --
    07 Oct 2015 01:13 PM
    Thank you! That realy did the trick!
    Filip DušekUser is Offline
    Advanced Member
    Advanced Member
    Posts:695


    --
    07 Oct 2015 01:33 PM
    OK, I will included fix in the next release.
    You are not authorized to post a reply.